Search found 222 matches

by Doug
Wed May 05, 2021 8:44 pm
Forum: Announcements
Topic: Version 1.0.0 Released
Replies: 5
Views: 37

Version 1.0.0 Released

Version 1.0.0 of the Buildbotics Controller has been released! Version 1.0.0 software is now available with many improvements over 0.4.16. Here are the highlights: Programmable macro buttons - yep, you can now assign gcode programs to buttons and execute them with a single button click. Improved 3D...
by Doug
Wed May 05, 2021 7:58 am
Forum: User Developments
Topic: bor 454 DIY
Replies: 4
Views: 26

Re: bor 454 DIY

Great job!
by Doug
Sun May 02, 2021 7:25 pm
Forum: Buildbotics Tech Support
Topic: Issues using G53 or G92.2 in Tool Change Script
Replies: 7
Views: 138

Re: Issues using G53 or G92.2 in Tool Change Script

I submitted a bug report in our github repository. See https://github.com/buildbotics/bbctrl-f ... issues/297

I cannot say for certain that it will be fixed in V1.0.1. At least the issue is documented.

Thank you for bringing the issue to our attention.
by Doug
Sun May 02, 2021 11:56 am
Forum: Buildbotics Tech Support
Topic: Issues using G53 or G92.2 in Tool Change Script
Replies: 7
Views: 138

Re: Issues using G53 or G92.2 in Tool Change Script

I reduced the program to this: G90 G94 (Absolute distance mode; Feed in units per minute) G17 (using XY plane) G21 G53 G0 Z85 F600 G53 G0 X0 Y85.8 M30 % This took the tool change out of the picture and just executes the G53 commands. Sure enough, this cause the Y and Z lines in the axis table to tur...
by Doug
Mon Apr 26, 2021 6:22 pm
Forum: Buildbotics Tech Support
Topic: Issues using G53 or G92.2 in Tool Change Script
Replies: 7
Views: 138

Re: Issues using G53 or G92.2 in Tool Change Script

Please attach a short gcode program that provides an example of this behavior and I will try to duplicate the issue here.
by Doug
Sat Apr 10, 2021 9:02 am
Forum: Buildbotics Tech Support
Topic: Slave motor lag during default program run
Replies: 4
Views: 263

Re: Slave motor lag during default program run

If you press the yellow 'Y' button on the gamepad, then gamepad moves will travel at the 'max-velocity' that is set for the axis. In most cases, 5 meters/minute is easily achievable. You have to configure each axis on the respective motor pages. Have you done that? If so, can you report the settings...
by Doug
Fri Apr 09, 2021 7:55 pm
Forum: Buildbotics Tech Support
Topic: Slave motor lag during default program run
Replies: 4
Views: 263

Re: Slave motor lag during default program run

How are you determining the actual velocity of the rapid moves on the Y axis? Keep in mind that the velocity that is displayed on the Control page is the vector sum of the velocity in all directions, so if you are moving in two directions, the velocity displayed will be greater than the maximum velo...
by Doug
Fri Apr 02, 2021 10:09 pm
Forum: Announcements
Topic: CarveCo
Replies: 0
Views: 261

CarveCo

CarveCo has created post processors for the Buildbotics Controller. You can download them from our Github Post Processor Library..

Check out their CAD/CAM products here.

Thanks CarveCo.
by Doug
Fri Mar 19, 2021 10:20 am
Forum: Buildbotics Tech Support
Topic: Deceleration on steppers
Replies: 2
Views: 305

Re: Deceleration on steppers

First, let me say that you can adjust the distance it takes to accelerate and decelerate by changing the max-acceleration an max-jerk fields on the motor configuration pages. Try increasing each of these by a factor of 10 to see how it reacts. Then, play around with it until you get feel that is com...
by Doug
Tue Mar 16, 2021 1:09 pm
Forum: Buildbotics Tech Support
Topic: How to eject a USB
Replies: 1
Views: 258

Re: How to eject a USB

This happens because the "dirty' bit gets written by the Raspian Linux system in the Buildbotics Controller but does not clear it. Then, when Windows sees that the "dirty" bit is set, it complains. You should be able to simply ignore the complaint and continue to load the drive on Windows. I am not ...