Version 1.0.0 Released

Announcements of general interest
Forum rules
No profanity, No gambling. No porn. No illegal activity of any kind. Violators will be removed without notice.
Post Reply
User avatar
Posts: 326
Joined: Fri Feb 02, 2018 4:56 pm

Version 1.0.0 Released

Post by Doug » Wed May 05, 2021 8:44 pm

Version 1.0.0 of the Buildbotics Controller has been released!

Version 1.0.0 software is now available with many improvements over 0.4.16. Here are the highlights:
  • Programmable macro buttons - yep, you can now assign gcode programs to buttons and execute them with a single button click.
  • Improved 3D cut path now has its own page. You'll have to see it for yourself, but trust me, it's a lot better.
  • The camera view now has its own page.
  • GCode Editor - That's right, you can now edit your GCode from in the Buildbotics Controller
  • Simplified Control page - The old page was too busy and some things have been moved to other places.
  • All configuration changes are now done from the 'SETTINGS' page.
  • Greatly improved GCode file management.
  • Added support for many more game pad controllers.
  • The onscreen keyboard is greatly improved.
  • The manual has been upgraded to reflect these changes.
You will probably notice a whole bunch of small changes as well. Here's the whole list:
  • Modbus debugging has been improved.
  • Max-arc-error and max-deviation are now a single configuration parameter.
  • Fixed axis, offset, and position displays in the axis table.
  • Fixed zero-all button when some axes are homed and others are not.
  • Fixed default units handling. BTW, you can now create a Macro button to set the units with a single button click.
  • Added our copyright statement to the LCD boot up display. Don't worry, it's still Open Source.
  • Added support for the DMM DYN4 Variable Frequency Drive
  • Improved the tool tip for axis 'Under' and 'Over' states.
  • The default WiFi configuration is set to 'internal'.
  • Pauses during seeking operations are now handled correctly.
  • Fixed centering on boot up splash screen
  • Moved documentation pages to DOCS Page.
  • Multiple files can now be uploaded simultaneously.
  • A progress bar is now presented when uploading files and upgrading firmware.
  • A warning is now presented when leaving the SETTINGS Page without saving changes.
  • Fixed a problem that occurred when entering config changes while the virtual keyboard was active.
  • Fixed error that occurred when setting the lower soft limit with a virtual keyboard installed. (See github issue #249)
  • Moved 'Save' button to the SETTINGS Page.
Let us know what you think.

Posts: 3
Joined: Fri Feb 12, 2021 9:35 am

Re: Version 1.0.0 Released

Post by Amos246 » Thu May 06, 2021 6:16 am

I'm not seeing the upgrade option when I turn controller on

Posts: 11
Joined: Tue Mar 23, 2021 2:36 pm

Re: Version 1.0.0 Released

Post by rtkracht » Thu May 06, 2021 8:56 am

I've been playing around with the macro buttons. (1) I can create a button, but when I update the gcode, the button still executes the old code. (2) There seems to be no way to delete an old file. Everything seems to be grayed out (3) After the macro executes it runs the gcode program-start... not exactly what I was anticipating or wanting.
Update 7:30 pm...
After working with the macro buttons I found they are very inconsistent and I'm not sure what's causing it. They were working earlier today (I've got two 2 line macros) but now neither works. You click a button and it goes directly to running the gcode in the program-start section and no execution of the macro code(s). I'm certainly no expert but I think there's a problem with the file handling somewhere.
Update 9:30 am 7 May 2021...
I've been trying to identify the circumstances regarding my macro buttons not working. As I was documenting this issue I just noticed that hovering the cursor over the buttons shows the file name of the gcode file being executed and both buttons have the name for the gcode for the ASPIRE job I'm cutting... NOT the code that I originally loaded for each button. No wonder it seems like it goes to program-start section. Something weird is going on with the file system. I went to the macro section and changed the references to the correct files, saved and tried again. No luck. Still the same behavior even though the file references are correct. ... r.jpg?dl=0
After a reboot, same issue. Macro does not run. You can see the code in the lower part of the image but it is trying to execute the program-start code (probing).
Update 12 May 2021...
OK, Doug straightened me out. Program-start runs for everything, a full job or a short macro. So moving my probing code to program-start solved most of my problem. I did a full day of cutting with few issues. More tomorrow.
Last edited by rtkracht on Wed May 12, 2021 5:54 pm, edited 5 times in total.
Huffman, TX

bor MC
Posts: 31
Joined: Wed Mar 04, 2020 2:03 pm
Location: Grandy, NC

Re: Version 1.0.0 Released

Post by bor MC » Thu May 06, 2021 9:43 am

Have got the machine at work updated and dialed in with some new macros buttons. Basic commands like Park, Go To Home, Probe, etc. put this machine right on par with our other routers now making it easier for all operators to use. I can't wait to get home and update the machine there too.

Great job guys!
Work Macros.png

*Update* Finally made it home and got to play with setting up the buttons on the machine here. Got to tell you I love the onboard g-code editing feature. All I had to do is upload the same macros files from the work mac, open them in editor, change a few numbers and save. What a cool feature.

I haven't been able to run any other files yet but the buttons have me very happy. Again great work guys!! Thank you.
Last edited by bor MC on Thu May 06, 2021 2:16 pm, edited 4 times in total.

Posts: 11
Joined: Tue Mar 23, 2021 2:36 pm

Re: Version 1.0.0 Released

Post by rtkracht » Thu May 06, 2021 9:54 am

Another little problem... when I opened by gcode job, the code didn't display but my test macro button code showed in it's place. ... M.jpg?dl=0

The file name is correct, it cuts correctly but no 3d simulation.
Huffman, TX

Posts: 12
Joined: Tue Jun 04, 2019 1:56 pm

Re: Version 1.0.0 Released

Post by jefflangendoerfer » Thu May 06, 2021 1:30 pm

Hello Doug,
I had 2 issues with 1.0.0

Installed fine,
Ran one short program, and the program finished before the display of G code and axis movement graphics did. Graphics were still running after the program finished. BB Box showed the axis were parked

2nd issue
Loaded up a larger program, and the 3d view still had the first programs display, and would not switch. the program itself appeared to run fine.

Ran both programs cutting air.

ps- THANKS FOR THIS UPDATE, thanks for all the work you do!


Posts: 3
Joined: Tue Apr 20, 2021 6:14 am

Re: Version 1.0.0 Released

Post by satgod » Wed May 26, 2021 8:32 pm

been using this since it showed a update available on my controller screen

what i've notices is after a carve is done, everything is off but the web screen for the controller shows the same file running again but there is no movement from the cnc just the gcode scrolling and that status bar moving across the screen. While this is going on I have no control of the machine and clicking stop does not always stop it. several times i've had to use estop to stop it, which then wipes out my home positions so if I'm wanting to change tools i'm kinda screwed

Posts: 12
Joined: Tue Jun 04, 2019 1:56 pm

Re: Version 1.0.0 Released

Post by jefflangendoerfer » Mon Jun 14, 2021 11:05 am

I am still having major issues with this new version.

-seams sluggish

-G code continues to run even after I stop the program

-Freezes up occasionally

-It doesnt like to switch from showing G code running to 3d cutting path view

-I have to reset it after every run

Is any one else experiencing these issues?

I have the controller plugged into the back of my router that is approx 15 feet from the controller and then control the box with a small PC that is wireless to the same router...

Posts: 4
Joined: Fri Nov 06, 2020 1:20 pm

Re: Version 1.0.0 Released

Post by callen » Thu Aug 19, 2021 1:36 pm

Two things I noticed on the new firmware.
1. When using the a screen connected to the HDMI port of the controller when ever you go to input text in any field the virtual keyboard pops up. Would be great to turn off the auto pop up in the settings. I no longer have a touch screen and when i go to type something from the physical keyboard it always pops up.
2. Would be nice to be able to move files with either a drag and drop or select them from the menu then click move. Right now if you create or put a file in a folder, you can't move it later.

Would be great to see this implemented.


Post Reply