error apt --fix-broken install

Post technical questions about the Buildbotic Controller here.
Forum rules
No profanity, no gambling, no illegal activity, so sexual or pornographic material.

Posts not related to the Buildbotic CNC Controller are likely to be moved or deleted.
Post Reply
tdwebste
Posts: 6
Joined: Thu Jan 02, 2020 11:22 pm

error apt --fix-broken install

Post by tdwebste » Sat Feb 01, 2020 11:27 am

The systems is working.
And I can get by with command line vi
I don't need to install vim-gtk
Can I just ignore this error?

Trying to install vim-gtk
sudo apt-get install vim-gtk

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:

When I run apt --fix-broken install

sudo apt --fix-broken install
The following additional packages will be installed:
raspberrypi-bootloader raspberrypi-kernel
The following packages will be upgraded:
raspberrypi-bootloader raspberrypi-kernel

Do you want to continue? [Y/n] Y
Reading changelogs... Done
(Reading database ... 53792 files and directories currently installed.)
Preparing to unpack .../raspberrypi-kernel_1.20190819~stretch-1_armhf.deb ...
Adding 'diversion of /boot/bcm2708-rpi-b-plus.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b-plus.dtb by rpikernelhack'
dpkg-divert: error: error checking '/boot/bcm2708-rpi-b-plus.dtb': Read-only file system
Adding 'diversion of /boot/bcm2708-rpi-b.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b.dtb by rpikernelhack'


This repeated Read-only file system error prevents the fixing the package error

User avatar
Doug
Posts: 161
Joined: Fri Feb 02, 2018 4:56 pm

Re: error apt --fix-broken install

Post by Doug » Sun Feb 02, 2020 7:46 pm

Why do you want to install vim-gtk?

Post Reply