Position flips sign at low feeds bug report and work around

Post technical questions about the Buildbotic Controller here.
Forum rules
No profanity, no gambling, no illegal activity, so sexual or pornographic material.

Posts not related to the Buildbotic CNC Controller are likely to be moved or deleted.
Post Reply
Matthew McMillion
Posts: 2
Joined: Sat Mar 06, 2021 12:10 pm

Position flips sign at low feeds bug report and work around

Post by Matthew McMillion » Sat Mar 06, 2021 2:24 pm

I was doing some fly cutting at 2IPM using MDI and noticed some unusual behavior. This behavior was repeatable from any location on the table and when run from a program. I only experimented in x axis, but this behavior may repeat for the others.
My program code was: "G01 G90 X-6.0 F2.0"
After travelling beyond -4.0" the machine would hick-up as if it lost steps and the position readout would flip sign to +4.**" It would continue feeding trying to get to -6" but would repeat the hickup and sign flip when it reached -4.**" again. It would continue this indefinitely. It also occured if I tried to go to +6" in my g-code but with all signs reversed.
After trying several things without affect, I found that if I changed the feed this fault would happen at different locations.
At 1IPM it was ~2"
At 2IPM it was ~4"
At 3IPM it was ~6"
At 4IPM it was ~8"
The pattern is approximately 2xfeed...on my machine.

I was able to work around this by breaking the long travel segment up into smaller chuncks or by using a feed that was higher. I think though, that long linear moves on larger machines could run into this problem at higher feeds based on the pattern here.

Things I tried that did NOT change the behavior.
Changing microstepping.
Changing Acceleration.
Changing Jerk.
Disabling limit switches.
Updating firmware from .4* to most current (New layout and features look awesome btw!)

I also didn't try any mult axis moves or arc moves to see if the problem occurred there. I mention it because others may be having this issue and need a work around and maybe it's something fixable in the code. My lead on the ballscrew would affect the distance travelled so I'll report that too (2.5mm).

Cheers!

User avatar
Doug
Posts: 217
Joined: Fri Feb 02, 2018 4:56 pm

Re: Position flips sign at low feeds bug report and work around

Post by Doug » Sun Mar 07, 2021 4:06 pm

Thank you for reporting this issue. I have duplicated it here and we will look into it.

User avatar
Doug
Posts: 217
Joined: Fri Feb 02, 2018 4:56 pm

Re: Position flips sign at low feeds bug report and work around

Post by Doug » Sun Mar 07, 2021 7:37 pm

This will be fixed in release 1.0.

Matthew McMillion
Posts: 2
Joined: Sat Mar 06, 2021 12:10 pm

Re: Position flips sign at low feeds bug report and work around

Post by Matthew McMillion » Sun Mar 07, 2021 8:07 pm

Wow! On a Sunday too! Great!

Post Reply