VFD/Spindle causing Controller to Crash

Post technical questions about the Buildbotic Controller here.
Forum rules
No profanity, no gambling, no illegal activity, so sexual or pornographic material.

Posts not related to the Buildbotic CNC Controller are likely to be moved or deleted.
Post Reply
leschyna
Posts: 1
Joined: Tue Oct 22, 2019 5:31 pm

VFD/Spindle causing Controller to Crash

Post by leschyna » Sat Nov 02, 2019 4:20 pm

When I "dry run" a file (Spindle off), it appears as if the program runs well and to completion, however, as soon as I power up the VFD/Spindle then I run the same code, somewhere after starting the program/controller crashes.

Yes, I understand about the RFI and cable routing etc... However, I have had two controllers on this very machine/build and they both were not affected. The new buildbotics controller is in the exact same location, nothing else changed.

Is this controller that much more sensitive... Not having looked at a schematic, is there RFI filtering on the input/output?

Any ideas for a fix?

Thanks

ZaneBen
Posts: 1
Joined: Wed Sep 11, 2019 2:24 am

Re: VFD/Spindle causing Controller to Crash

Post by ZaneBen » Tue Nov 12, 2019 5:49 am

Did you manage to pinpoint what the problem was, Leschyna?

User avatar
Doug
Posts: 52
Joined: Fri Feb 02, 2018 4:56 pm

Re: VFD/Spindle causing Controller to Crash

Post by Doug » Wed Nov 13, 2019 3:07 pm

When we last spoke, he reported that he rerouted his spindle cable to separate it from the power cable serving the Buildbotics Controller and the problem went away.

User avatar
chuckt
Posts: 5
Joined: Fri Nov 15, 2019 4:12 pm

Re: VFD/Spindle causing Controller to Crash

Post by chuckt » Sat Nov 16, 2019 12:01 pm

Look for "gound loops". Make sure everything is grounded to a common (or nearly common) location.
-------------------------------------------------
All the best,
Chuck Tilbury
http://whistlemaker.com

Post Reply